Raspberry Pi Forum

Welkom op dit NIEUWE Raspberry Pi Forum! Plaats jouw projecten - vragen & berichten!

Gebruikersavatar
By Ruud
#183
Hallo Allemaal,

In het nieuwe Elektor blad stond een project met een pico, om een LED aan te kunnen sturen met een telefoon of een computer. Ik heb een en ander in elkaar gezet, maar ik krijg constant een foutmelding, die mij niet zoveel zegt.
Weet iemand wat er fout kan zijn?

Ik zal de listing en de fout hieronder neerzetten.
Uiteraard heb ik SSID en Password voor mijn netwerk goed ingevuld.

#----------------------------------------------------------
# USING WI-FI
# ===========
#
# In this project a ESP-01 chip is connected to the Raspberry
# Pi Pico. This chip is used to connect the Pico to the Wi-Fi
#
# Author: Dogan Ibrahim
# File : Picowifi.py
# Date : February 2021
#------------------------------------------------------------
from machine import Pin, UART
import utime
uart = UART(0, baudrate=115200,rx=Pin(1),tx=Pin(0))

LED = Pin(16, Pin.OUT)
LED.value(0)

#
# Send AT commands to ESP-01 to connect to local WI-Fi
#
def ConnectToWiFi():
uart.write("AT+RST\r\n")
utime.sleep(5)

uart.write("AT+CWMODE=1\r\n")
utime.sleep(1)

uart.write('''AT+CWJAP="SSID","PASSWORD"\r\n''')
utime.sleep(5)

uart.write("AT+CIPMUX=0\r\n")
utime.sleep(3)

uart.write('''AT+CIPSTART="UDP","192.168.178.75",5000,5000,2\r\n''')
utime.sleep(3)

ConnectToWiFi()

#
# Main program loop
#
while True:
buf = uart.readline() # Read data
dat = buf.decode('UTF-8') # Decode
print(dat)
n = dat.find("LON") # Includes LON?
if n > 0:
LED.value(1) # LED ON
n = dat.find("LOFF") # Includes OFF?
if n > 0:
LED.value(0) # LED OFF

===========================================================
De foutmelding:

>>> %Run -c $EDITOR_CONTENT
AT+RST



OK

WIFI DISCONNECT



ets Jan 8 2013,rst cause:2, boot mode:(3,7)



load 0x40100000, len 1856, room 16

tail 0

chksum 0x63

load 0x3ffe8000, len 776, room 8

tail 0

chksum 0x02

load 0x3ffe8310, len 552, room 8

tail 0

chksum 0x79

csu
Traceback (most recent call last):
File "<stdin>", line 45, in <module>
AttributeError: 'NoneType' object has no attribute 'decode'
>>>

Ik wil graag ook een hdmi poort gebruiken om een g[…]

USB wifi antenne

heeft nu helemaal niemand een idee welke externe a[…]